Fisker Buzz Forums banner
1 - 11 of 11 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter · #1 ·
I'm looking to buy a Karma and just before the purchase the cars command center went blank. The dealer and there tech has been on the phone with Fisker and they have done what they have told them to do in terms of resets and they still get nothing from the system. The cluster lights up, but anything that is tied to the MMI system does not. They have suggested they take the console off and do some other investigating still not knowing what the problem may be. Has anyone run into this problem as they are willing to discount the price if I buy the car as is but I need to know what I'm getting into. Any help much appreciated!
 

·
Registered
Joined
·
996 Posts
Does the car turn on? Does it drive? Does the cluster stay on after the EVER button is pressed? The cluster will turn on whenever the door is opened after the car has been sleeping.

Could be a bad Command Center, key not being recognized (if the car does not turn on), bad 12v battery. Need more information about what events trigger the cluster on and if the car is operable.
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #3 ·
From what I've been told by the dealer the car turns on, the cluster stays on, and the car is operable. The issue started when the dealer changed the keyfob battery however the key currently does lock and unlock the car, and it is recognized to start the vehicle also. Thank you for your help!
 

·
Premium Member
Joined
·
57 Posts
Harleyguy is your guy. Harleyguy is here local and so very smart. Im sure he could get you going and just an FYI we are having a south Florida meet up Saturday

Re: Meet up for luncheon Jan 18th 12 noon

I have made a reservation at Eduardo de San Angelo
2822 Commercial Blvd.
Fort Lauderdale
Approx cost per person $50.00
We do not have to guarantee more than 10 people and they will be flexible until the day before the luncheon.
I still do not have a complete count (see my previous post)
I have put this on my credit card so would appreciate your bringing a check or cash to the luncheon.

I am sure that we will have much to discuss by Jan 18th so this should be a fun event
Michael Nash
 

·
Registered
Joined
·
996 Posts
So I assume the dealer did do the "Hard Reset" with no change in CIU behavior? Have you tried to touch the screen in the general vicinity (a few inches from the bottom left) of where the I agree button would be? Do you feel a tactile click? There was an issue where the touch screen would respond but there would be no display. This was fixed after 615.
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #6 ·
The dealer did perform a hard reset and the ciu remained blank. The software version is currently unknown and the vehicle is out of state so I am not sure about the responsiveness of the screen to the agree button. I will contact the dealer and have them try that next and report back. Thanks!
 

·
Registered
Joined
·
31 Posts
Hey guys, this points more to the TPI (touch panel interface) itself.
The "Fisker Logo" is stored within the TPI. Regardless if CIU is present or not (working or not), the touch screen should ALWAYS display a "Fisker logo"

The CIU then takes over the display and performs the rest of the operation starting with the "agree" screen.

If the Fisker Logo is not even shown, then something is definitely wrong with the TPI.

NOW with the TPI there are mostly 2 parts. the touch panel part, and the screen display part. Regardless of the screen display, the touch panel will send command back to the CIU.
Have you dealer try this:
1. Start the car
2. wait about 45 seconds
3. press the bottom left corner where usually the "agree" button is
4. wait about 2 minutes
5. press the "voice recognition" button on the steer wheel

This process will debug the following:
1. If all the above works, you should hear voice command prompt from the sound system. This means the touch layer is working, the display layer is broken.
2. The CIU itself is not damaged and working properly.

Now, the screen display:
1. Check the display cable make sure it's not severed (the big round thick cable behind the TPI)
2. Check the display cable on the CIU end
3. If all above checks out, then you have a bad TPI... it has to be replaced as a whole.
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #8 · (Edited)
Thanks for the info but none of the steps you suggested worked and the dealer is not willing to pull the CIU apart so I'm at a tough decision whether to purchase this car, even at a steep discount. Any idea what a tPI replacement would cost?
 

·
Premium Member
Joined
·
3,077 Posts
I've all ready been in touch with the selling dealer and the buyer more then likely the TPI is the problem . As mentioned the logo always shows up even with a CIU failure . The said the problem was there before they programmed the key . I also suggested to them it would be faster to swap another screen from another car then waiting on Fisker . But I did tell them to contact Fisker so they understand the problem .
Regardless of what's going on with Fisker I still give them reports on what's going on with the Krama
 
1 - 11 of 11 Posts
Top