Fisker Buzz Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
After updating software version 05.03.99.00 about week and half ago from Fisker dealer, something strange happened... My nav system not working it says Activation... Navigation system not Activated contract your local dealer for system installation. Then my sound system goes to the most terrible sound ever, like front center speaker goes loulder than my front door speaker and so as you listen to any music fm radio xm radio or usb music... Sound so terrible, I had to turn off the volume to just not to get angry at myself. I was not sure maybe there is no sound coming from door speakers, sure enough it does come out but so much little volume compare to the center speaker is going crazy.
Not sure why this is happening, before the software update, I never had this issues and speakers sound amazing... Also of cause nav system is not working at all so b/u camera is not working. Does any one had same issues as mine? My vin is 214 and I am thinking can you go back to old software ver. Or im just thinking crazy. I can live without navigation but I like to have a backup camera and how can I make this awful speaker sound go back to the normal stage...

Paul from thomasville ga
 

·
Premium Member
Joined
·
3,077 Posts
After updating software version 05.03.99.00 about week and half ago from Fisker dealer, something strange happened... My nav system not working it says Activation... Navigation system not Activated contract your local dealer for system installation. Then my sound system goes to the most terrible sound ever, like front center speaker goes loulder than my front door speaker and so as you listen to any music fm radio xm radio or usb music... Sound so terrible, I had to turn off the volume to just not to get angry at myself. I was not sure maybe there is no sound coming from door speakers, sure enough it does come out but so much little volume compare to the center speaker is going crazy.
Not sure why this is happening, before the software update, I never had this issues and speakers sound amazing... Also of cause nav system is not working at all so b/u camera is not working. Does any one had same issues as mine? My vin is 214 and I am thinking can you go back to old software ver. Or im just thinking crazy. I can live without navigation but I like to have a backup camera and how can I make this awful speaker sound go back to the normal stage...

Paul from thomasville ga
What software was done on the car ?? Seems to me you might have two problems if the CIU got wet that would account for the speaker problem and it can cause the Nav to stop working. Also depending what and how they did the software you might need to have the CIU re flashed with the 510 files time to bring it back to the dealer that worked on the car.
 
1 - 3 of 3 Posts
Top