Fisker Buzz Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter · #1 ·
Hi all - just swapped my Panamera Turbo for a Fisker Karma.

Had it delivered to my office and just drove it home. I plugged the charger in and no lights on the charger came on. I tried a few different outlets and no lights on the charger.

I plugged it into the car anyway and the fans came on. Is it possible that the charger is working but the lights are just not showing?
 

·
Premium Member
Joined
·
4,659 Posts
adam said:
Hi all - just swapped my Panamera Turbo for a Fisker Karma.

Had it delivered to my office and just drove it home. I plugged the charger in and no lights on the charger came on. I tried a few different outlets and no lights on the charger.

I plugged it into the car anyway and the fans came on. Is it possible that the charger is working but the lights are just not showing?
Adam: I assume you attempted to turn the charger on using the large button? You have to push it down pretty hard to make it engage and you can also select between 6A and 12A draw by pushing that button repeatedly. The number of LEDs lit corresponds to the current draw. Half the LEDs indicate 6A and all the LEDs lit indicates 12A draw.

The fans coming on just means that the car has detected the charging connector being plugged in. It does not mean that any current is flowing. You should check the energy flow screen with the car in ACC mode to see if the charge percentage goes up to confirm charging.

-- Fab.
 

·
Registered
Joined
·
20 Posts
Discussion Starter · #3 ·
Fabulist said:
Adam: I assume you attempted to turn the charger on using the large button? You have to push it down pretty hard to make it engage and you can also select between 6A and 12A draw by pushing that button repeatedly. The number of LEDs lit corresponds to the current draw. Half the LEDs indicate 6A and all the LEDs lit indicates 12A draw.

The fans coming on just means that the car has detected the charging connector being plugged in. It does not mean that any current is flowing. You should check the energy flow screen with the car in ACC mode to see if the charge percentage goes up to confirm charging.
Thanks for the reply - you are correct. When I plug it in, it detects the connector and makes a couple of noises but I can confirm it's not charging.

I've tried pushing the large orange button many times to no avail. I've asked teh dealer to deliver a new one to me. Bummer. Amazing - they take it out for a test drive, apply 6.13, the grounding strap and then skip over testing to see if the charger actually works. I'm guessing they have the 220v chargers at the dealership and don't actually use the chargers the cars come with.
 

·
Registered
Joined
·
435 Posts
wonder how it works here in europe. Since we have 220V and I pay the same rate regarding when charing I was just planning to use the device that is included in the car
 

·
Premium Member
Joined
·
1,975 Posts
adam said:
Hi all - just swapped my Panamera Turbo for a Fisker Karma.

Had it delivered to my office and just drove it home. I plugged the charger in and no lights on the charger came on. I tried a few different outlets and no lights on the charger.

I plugged it into the car anyway and the fans came on. Is it possible that the charger is working but the lights are just not showing?
Adam

So you finally decided to make the switch! Congrats and welcome - curious what put you over the edge, which Karma you got, etc. etc (and how you got a Karma so quickly)! Share with us your experience and thoughts!
 
1 - 6 of 6 Posts
Top