Fisker Buzz Forums banner
1 - 18 of 18 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
Hi,



I have a new fisker karma that has only 100 miles on it. 4 month ago the car was ok and i could switch between STEALTH and SPORT mode. last day i installed a new 12v battery and ever since the car shows REDUCED performance limp failure. and the car paddle behind the steering is not switching from stealth to sport at all. any idea whats going on??? i did few soft and hard reset but still nothing. all gauges looks fine no reds but the MSG performance reduced and limp failure is still on.




thanks guys for helping
moe is online now Report Post
 

·
Deep Ocean in ATL
Joined
·
436 Posts
Harley and Philly please chime in. I recall them telling to do a hard reset from under the hood if the 12 batter was completely dead.
 

·
Premium Member
Joined
·
4,662 Posts
Hi,



I have a new fisker karma that has only 100 miles on it. 4 month ago the car was ok and i could switch between STEALTH and SPORT mode. last day i installed a new 12v battery and ever since the car shows REDUCED performance limp failure. and the car paddle behind the steering is not switching from stealth to sport at all. any idea whats going on??? i did few soft and hard reset but still nothing. all gauges looks fine no reds but the MSG performance reduced and limp failure is still on.




thanks guys for helping
moe is online now Report Post
Hello @moe, and sorry that you had to post the dreaded "Reduced Performance" question. While we wait for the real experts to chime in, there has been a fair amount of discussion about this issue on prior threads such as this, this and this, just for three examples. Unfortunately, the problem is generally a serious one and requires serious surgery by an expert. Best of luck and we are all wishing you a good outcome.
 

·
Registered
Joined
·
1,091 Posts
Yes @moe it can be a serious concern. The most important is that you don't continue to drive it like that. The ICE or generator has registered a fault and has shut down so you will only run off of battery which can damage the HV battery if you run it too low.
in theory if you replaced the 12v battery then you've done a hard reset already. before I guess on the issue, it needs to be connected to a Fisker scan tool or at least the OBD generic codes to start. Also, where are you located
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #5 ·
@Fiskerphily can it be a FALSE ALARM???? and it might go away after couple of shut down and drive?? because the car battery charge perfect and give me a good range. the only thing is the stealth mode won't let me to switch to sport mode. i live close to DUBAI and i believe there is a service centre in DUBAI. thanks for the reply
 

·
Registered
Joined
·
1,091 Posts
Likely not a false alarm. But you're welcome to try shutting down and restarting as many times as you wish. See what happens. I'm sure hv battery and external charging sounds like no issues. Your problem is strictly with GEN SET or gas engine/generator.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #7 ·
@FiskerPhilly so what are my options?? is there anything that i can do? or flatbed the car to Dubai where to service centre is located. it feels really bad i can't believe that happen at 180 km only almost new car ;(
 

·
Registered
Joined
·
1,091 Posts
@FiskerPhilly so what are my options?? is there anything that i can do? or flatbed the car to Dubai where to service centre is located. it feels really bad i can't believe that happen at 180 km only almost new car ;(
Unfortunately yes if Reduced performance message keeps coming on then codes need to be read from hybrid and engine management systems with scan tool.
As far as mileage, as many owners can attest it doesn't mean much. I've probably done more major repairs on the cars that sit too long. Think about batteries and how well they tolerate lack of use.
good luck and reach out if you need any advice once it's at the dealer.
 

·
Registered
Joined
·
146 Posts
Moe

The problem may be the Generator Harness.

The had the same problem and it was very frustrating. The engine would not start and the vehicle would not go into Sport's mode. I drove on battery only. I had the front inverter replaced and it seem to fix the problem but it soon came back. I sent the old inverter to Fisker for testing and it turned out the inverter was not the problem.

I drove the vehicle in battery mode only for about 4 months until Fisker restored the warranty since I had to pay for the other repair that did not fix the problem. When the battery starts to run low I make a bee line home to charge. On a couple occasions I ran the battery all the way down with about 10 miles from home and to my surprise I still made it home using the reserve portion of the battery that is usually not accessible. As others have said this could damage the battery. Fortunately for me my battery is just find.

The problem turn out to be the Generator Harness.

On the repair invoice it states: "Test and diag and remove necessary components to access Generator Harness and disassemble harness/clear codes and road test multiple times. Motor stayed running and code did not return". Hope this help. Good Luck!

Samuel
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #13 ·
@scurry1074 hey samuel first of all thank you for your help i really appreciate it. and about the generator harness is it easy to fix. i mean In my town i do not have any fisher service centre so do you think and good garage will be able to fix the problem. what a happy news to hear ;)



moe
 

·
Registered
Joined
·
146 Posts
Moe

The Fisker dealer here in Michigan did the repair with the help from Fisker Support so I don't know how diffficult this was to repair.

Also, it turned out that the Generator Harness is what was causing my problem and this was just a suggestion of what could be causing yours. However, this problem can be brought on by other systems involving your vehicle and it needs to be diagnosed and repaired by a train Fisker technicain.

To answer your question, no, I don't think a good garage mechnic can fix this problem without the Fisker scan tools and a Fisker technicain instructing the mechanic on the procedure. I think you have to have a Fisker technicain involved.

HarleyGuy or FiskerPhilly may be able to help you. I thing that if you had a good mechanic following instructions from a Fisker technicain you can fix the problem. Think about it, what if you used some type of video conferencing such as facetime on a cell phone following the procedure and instructions outlined by one of the technicains mention, then yes you might be able to fix the problem. With the right instructions I believe I could have fixed the Generator Harness on my vehicle.

Samuel
 

·
Premium Member
Joined
·
3,077 Posts
The fix is to separate the generator harness from the engine harness . It's not a hard job to do but i don't feel its the problem his having .The codes really need to be read and see what that shows. I was actually the first one to the this repair for Fisker they never came out with an official bulletin not sure why . We had to separate the two harness from each other because of signal interference from the generator. If I remember correctly the car didn't have a running problem but a constant check engine light .
 
1 - 18 of 18 Posts
Top