Fisker Buzz Forums banner
1 - 10 of 10 Posts

·
Registered
Joined
·
223 Posts
Discussion Starter · #1 ·
First, I love my Karma. I treat it like royalty (it's entirely wrapped in Xpel Ultimate and cleaned after every drive). I updated the car up until a week before the bankruptcy. I do NOT have Baseline 520 yet, because I'm in Boston and driving to Philly is not easy to do with my work schedule, unfortunately.

Today I noticed that the radio presets suddenly were lost, the time zone setting was lost (defaults back to LA), as well as the ability to connect to my phone via Bluetooth. I'm very familiar with using the car and I'm sure I'm using the proper procedure to connect to my iPhone 6+. I tried soft resetting, no luck. Then for the first time in my entire ownership history, I tried hard resetting (unplugging the cable above the right front tire, waiting 30 seconds, then replugging). Still no luck. Tried swapping key fobs, playing with settings... No matter what I tried, the car shows the following dysfunctions, all of which are new:

- Upon start up, plays radio static because it has forgotten all radio presets and audio modes.

- Cannot pair with my phone over bluetooth, after trying everything including resetting my phone. I can get to the PIN code entry, but even after successfully entering the PIN code twice, it still never connects.

- Side mirrors do NOT auto fold even though I turned on auto fold, then turned it off and on, etc. etc. I know the mirror motors work because I can still manually fold and unfold them from the center console controls.

- Time zone data is reset to LA (pacific time) every time I start the car.

- Secondary time is active every time I start the car.

I assume that I need the car's software reflashed, if not more serious work done on the car. As I mentioned, however, I live in Boston and it would be tough given my work schedule (pretty much 7 days a week) to set aside the time to do a round trip drive to Philly. Is there any way to bring a Fisker tech to Boston? Or to ship my car to Fisker (using funds from my warranty allotment?) Or anything else I can do to reset the software and cure these frustrating bugs?

Thank you for your advice!
 

·
Registered
Joined
·
1,091 Posts
I will be picking up and delivering other cars in Boston area in the near future. You need the CIU reflashed/possibly hardware replacement. Common issue. I have 2 other Boston cars to repair. Just waiting to clear some space on the schedule to get to you guys.
 

·
Registered
Joined
·
223 Posts
Discussion Starter · #3 ·
Thank you so much, FiskerPhilly! Could you please message me when you have more firm plans for Boston? I am very eager to bring my Karma back to full health :)

Many thanks to you and your coworkers!
 

·
Premium Member
Joined
·
3,063 Posts
I might be in Boston in the coming month or two I need to go to Lamborghini school there . Will let you know the dates might be able to squeeze some time in for you .
 

·
Registered
Joined
·
87 Posts
Thank you so much, FiskerPhilly! Could you please message me when you have more firm plans for Boston? I am very eager to bring my Karma back to full health :)

Many thanks to you and your coworkers!
Hello drliu,
could you solve your problem. I am having exactly the same symptoms like you have. Channels gone, Bluetooth gone, ....
Thank you.
 

·
Registered
Joined
·
113 Posts
Seems like these things happen to many of us at once. Mine just did the same thing on Thursday, my car has 520. I assume the only fix it to re-flash? Does anyone know what causes this to happen?
 

·
Premium Member
Joined
·
484 Posts
Seems like these things happen to many of us at once. Mine just did the same thing on Thursday, my car has 520. I assume the only fix it to re-flash? Does anyone know what causes this to happen?
Hi Sterling500, Were they able to re-flash your CIU without any problems?
 
1 - 10 of 10 Posts
Top