Fisker Buzz Forums banner

1 - 20 of 38 Posts

·
Premium Member
Joined
·
1,975 Posts
Discussion Starter · #1 ·
Had my first flatbedding experience today. Now I feel like a real Karma owner :p. Dealership was closed, so Fisker HQ got flatbed co to pickup my car and store it until tomorrow when dealer is open. Shout out to Natalie @ Fisker HQ for her help.

Flatbedder had me drive the Karma onto the bed, which I thought was unusual and my Karma made some odd noises before stalling on the incline! After reversing and trying again, it made it.

Hope to get my Karma back by Easter with all of my issues resolved! I'll keep everyone posted!
 

·
Premium Member
Joined
·
1,975 Posts
Discussion Starter · #3 ·
WOJO said:
Sorry to hear that.
Oh, let me clarify - this was scheduled maintenance, not something unexpected or me getting stranded. I had coordinated with Fisker to get all my past issues fixed and so this weekend was the time for me to bring the car in so they could work on it. They did the flatbedding just because dealer was closed on Sunday.
 

·
Premium Member
Joined
·
4,659 Posts
SoCalGuy said:
Oh, let me clarify - this was scheduled maintenance, not something unexpected or me getting stranded. I had coordinated with Fisker to get all my past issues fixed and so this weekend was the time for me to bring the car in so they could work on it. They did the flatbedding just because dealer was closed on Sunday.
Hope you are reunited soon. Kudos to Fisker for coordinating the pick up on Sunday for your convenience.
 

·
Premium Member
Joined
·
17 Posts
Fabulist said:
SoCalGuy said:
Oh, let me clarify - this was scheduled maintenance, not something unexpected or me getting stranded. I had coordinated with Fisker to get all my past issues fixed and so this weekend was the time for me to bring the car in so they could work on it. They did the flatbedding just because dealer was closed on Sunday.
Hope you are reunited soon. Kudos to Fisker for coordinating the pick up on Sunday for your convenience.
You will miss it and realize how much fun it is to have. Everything else is "just" a car. :)
 

·
Registered
Joined
·
781 Posts
I've only been able to drive mine once since it's flatbed experience last week and it's already got to go back. I got the dreaded burned-out side mirror problem, so the car gets to sit in my garage until Friday when I have an appointment to haul it back in.

-Brian
 

·
Registered
Joined
·
242 Posts
had similar experience with Customer affairs since no dealer in AZ they arranged transport to Vegas- picked up from my home in closed car carrier- returned when requested right to my home. Coordinated with Roadside assistance and customer affairs and they were very thorough- calling all of the time to make sure drivers arrived on time, etc

turn off auto mirror retraction to prevent burn out of motor- can use touch button but not auto setting. hopefully in the 615 fix but...
 

·
Registered
Joined
·
784 Posts
brian said:
I've only been able to drive mine once since it's flatbed experience last week and it's already got to go back. I got the dreaded burned-out side mirror problem, so the car gets to sit in my garage until Friday when I have an appointment to haul it back in.

-Brian
Are you not allowed to drive with a burned-out mirror engine?! I remember reading you could simply push back the mirror in the right position and drive on. It just won't fold anymore. Or am I wrong?
 

·
EX:Shadow/Canyon #324
Joined
·
1,217 Posts
Dutch said:
brian said:
I've only been able to drive mine once since it's flatbed experience last week and it's already got to go back. I got the dreaded burned-out side mirror problem, so the car gets to sit in my garage until Friday when I have an appointment to haul it back in.

-Brian
Are you not allowed to drive with a burned-out mirror engine?! I remember reading you could simply push back the mirror in the right position and drive on. It just won't fold anymore. Or am I wrong?
That's what I did. Worked fine.
 

·
Premium Member
Joined
·
4,659 Posts
jscheel66 said:
Mine is getting the 615 update as we speak.. Holding my breath..

Jeff
You may not want to do that for the entire 4 hours it takes to do the update. May be a bit winded at the end. :p
 

·
Premium Member
Joined
·
1,975 Posts
Discussion Starter · #15 ·
Got my car back tonight after some limited drama - more to come on that front later. My car was updated to 6.15 and here's what I've noticed in the 60 miles or so I put on it this evening:


- My TPMS light still flashes on sometimes when I switch into Sport - had this problem also in 6.14.2 but not in 6.12
- My front proximity sensors don't appear to beep anymore - at all - the back ones work fine.
- My rear view camera has frozen with a black screen once so far (I guess the improvement was making the formerly green/blue screens black?)
- in Sport mode, the first few hundred/thousand feet or so appears to be in Stealth as I didn't hear the ICE kick in until a bit later - my battery even when the ICE kicked in depleted from 13 miles of range to 9 miles of range, and then slowly started to charge on the freeway back up to 13 miles (for a minute I thought they had restored the charge-increase mode we saw with the roadshow cars, but alas, it just charges it back up to the point you kicked it into Sport mode)
- Radio volume seems softer at the same levels - e.g. at level 5, that was plenty loud for me before, but now its too soft, so I punch it up to 7.
- The PRNDL has been dancing a lot - A LOT more than it used to. Not only the red PRNDL flashing but I also have noticed a green laser or two emitting fromt he PRNDL (while driving in Sport mode on the freeway) - seems more frequent than I remember with 6.12/6.14.2

That's all for now - more driving tomorrow.
 

·
Premium Member
Joined
·
3,063 Posts
SoCalGuy said:
Got my car back tonight after some limited drama - more to come on that front later. My car was updated to 6.15 and here's what I've noticed in the 60 miles or so I put on it this evening:


- My TPMS light still flashes on sometimes when I switch into Sport - had this problem also in 6.14.2 but not in 6.12
- My front proximity sensors don't appear to beep anymore - at all - the back ones work fine.
- My rear view camera has frozen with a black screen once so far (I guess the improvement was making the formerly green/blue screens black?)
- in Sport mode, the first few hundred/thousand feet or so appears to be in Stealth as I didn't hear the ICE kick in until a bit later - my battery even when the ICE kicked in depleted from 13 miles of range to 9 miles of range, and then slowly started to charge on the freeway back up to 13 miles (for a minute I thought they had restored the charge-increase mode we saw with the roadshow cars, but alas, it just charges it back up to the point you kicked it into Sport mode)
- Radio volume seems softer at the same levels - e.g. at level 5, that was plenty loud for me before, but now its too soft, so I punch it up to 7.
- The PRNDL has been dancing a lot - A LOT more than it used to. Not only the red PRNDL flashing but I also have noticed a green laser or two emitting fromt he PRNDL (while driving in Sport mode on the freeway) - seems more frequent than I remember with 6.12/6.14.2

That's all for now - more driving tomorrow.
I don't think it's your TPMS light that flashes more then likely it the low oil pressure /High temperature warning light that flashes .The next software release will cover that .It's the timing of the signal from the oil pressure switch too the ECM/VCM if you hear the same type ping when you switch from hill mode back and forth when the light flashes then it's the engine .

Not sure about the front sensors but they should work after the car goes to sleep and comes back online .

The Ice motor is working the same I've seen that since 614 I also notice now when driving off in Sport the engine kicks in a lot easier and is harder to detect .Going from Stealth too Sport the same thing very quite .

The PRNDL at the end of 615 they have a special procedure that needs to be done thats on page 29 of the campaign.

I personally feel the radio is working a lot better not but then again depending the area you live and the music you listen too might make it seem like it's not loud enough now .
I don't know of any changes in the radio update that would cause that .
I also think you need to go back too the Dealer and road test the car with the service manager to verify the problems .

Fisker wouldn't release this update until they logged 30,000 miles on the test cars so I'm sure your dealer would want to see the car back .

Also have you dealer check when they hook up the car to Prodis that all the Modules are showing the correct software numbers .
 

·
EX:Shadow/Canyon #324
Joined
·
1,217 Posts
Harleyguy said:
SoCalGuy said:
Got my car back tonight after some limited drama - more to come on that front later. My car was updated to 6.15 and here's what I've noticed in the 60 miles or so I put on it this evening:


- My TPMS light still flashes on sometimes when I switch into Sport - had this problem also in 6.14.2 but not in 6.12
- My front proximity sensors don't appear to beep anymore - at all - the back ones work fine.
- My rear view camera has frozen with a black screen once so far (I guess the improvement was making the formerly green/blue screens black?)
- in Sport mode, the first few hundred/thousand feet or so appears to be in Stealth as I didn't hear the ICE kick in until a bit later - my battery even when the ICE kicked in depleted from 13 miles of range to 9 miles of range, and then slowly started to charge on the freeway back up to 13 miles (for a minute I thought they had restored the charge-increase mode we saw with the roadshow cars, but alas, it just charges it back up to the point you kicked it into Sport mode)
- Radio volume seems softer at the same levels - e.g. at level 5, that was plenty loud for me before, but now its too soft, so I punch it up to 7.
- The PRNDL has been dancing a lot - A LOT more than it used to. Not only the red PRNDL flashing but I also have noticed a green laser or two emitting fromt he PRNDL (while driving in Sport mode on the freeway) - seems more frequent than I remember with 6.12/6.14.2

That's all for now - more driving tomorrow.
I don't think it's your TPMS light that flashes more then likely it the low oil pressure /High temperature warning light that flashes .The next software release will cover that .It's the timing of the signal from the oil pressure switch too the ECM/VCM if you hear the same type ping when you switch from hill mode back and forth when the light flashes then it's the engine .

Not sure about the front sensors but they should work after the car goes to sleep and comes back online .

The Ice motor is working the same I've seen that since 614 I also notice now when driving off in Sport the engine kicks in a lot easier and is harder to detect .Going from Stealth too Sport the same thing very quite .

The PRNDL at the end of 615 they have a special procedure that needs to be done thats on page 29 of the campaign.

I personally feel the radio is working a lot better not but then again depending the area you live and the music you listen too might make it seem like it's not loud enough now .
I don't know of any changes in the radio update that would cause that .
I also think you need to go back too the Dealer and road test the car with the service manager to verify the problems .

Fisker wouldn't release this update until they logged 30,000 miles on the test cars so I'm sure your dealer would want to see the car back .

Also have you dealer check when they hook up the car to Prodis that all the Modules are showing the correct software numbers .
The bug still exists that the front proximity sensors do not work when you are in Hill mode. If you switch to "D" the proximity sensors work fine.

I reported this bug 6-8 weeks ago but it did not get addressed in 6.15.
 

·
Premium Member
Joined
·
1,975 Posts
Discussion Starter · #19 ·
Update: I'll spare everyone the details of my drama with my dealer. Suffice it to say, I give kudos to Fisker corporate for all their help in getting at least some of my issues list items done by the time I picked it up.

After a weekend with my Karma, I had it picked up again so dealer could fix the remaining issues. I told them I wouldn't be back for 3 or so weeks, so they have plenty of time. Well, I suppose that was not enough time and they're so busy that Fisker HQ had to flatbed my Karma to another dealer much farther away that had capacity. Again, I'm very thankful to the VIP customer service team at Fisker HQ - my home dealer, however, is in the penalty box. If I do get another car from Fisker, it will be from another dealer :(
 

·
Premium Member
Joined
·
744 Posts
I hate to say it but I think some dealers might be hesitant to do their due diligence because they are worried about the future of Fisker. However, I am not sure how the costs are divided between dealer and corporate for warranty work. Anyone know for sure and not conjecture?
 
1 - 20 of 38 Posts
Top