Fisker Buzz Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hi All,

I've had my (black/black) Karma for a few days...... Although the software flash is only 6.13 Everything seems to work....I'm sure that's only temporary ;)
Glad to have found this forum, with all of the other advanced field testers.

Joe
 

·
Registered
Joined
·
2 Posts
RE: New owner SE Florida

Just picked up mine on sat, 1/28/12......only 50 miles so far......small problem with engine light icon......was told it may reset itself or to do a reset......unplug and replug battery under hood.......chose not to do that yet to see if the computer "learns" as they said it might.
anyway I am obviously # 86 for the Signature Series.

So far it was well worth the wait-----just afraid to park it anywhere, valet, etc. etc...
 

·
Premium Member
Joined
·
1,975 Posts
RE: New owner SE Florida

Karma 86 said:
Just picked up mine on sat, 1/28/12......only 50 miles so far......small problem with engine light icon......was told it may reset itself or to do a reset......unplug and replug battery under hood.......chose not to do that yet to see if the computer "learns" as they said it might.
anyway I am obviously # 86 for the Signature Series.

So far it was well worth the wait-----just afraid to park it anywhere, valet, etc. etc...
nice... are you also in Florida?
 

·
Registered
Joined
·
2 Posts
RE: New owner SE Florida

SoCalGuy said:
Karma 86 said:
Just picked up mine on sat, 1/28/12......only 50 miles so far......small problem with engine light icon......was told it may reset itself or to do a reset......unplug and replug battery under hood.......chose not to do that yet to see if the computer "learns" as they said it might.
anyway I am obviously # 86 for the Signature Series.

So far it was well worth the wait-----just afraid to park it anywhere, valet, etc. etc...
nice... are you also in Florida?
Yes.....Boca Area
 
1 - 5 of 5 Posts
Top