Fisker Buzz Forums banner
1 - 11 of 11 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
Hi All ,
Bilarone here from Morocco Africa , happy owner of a white Eco sport Fisker :) bought in Spain from official dealer that went bankrupt , I left my car charging during 24 hours and now I have a message indicating a HIGH voltage battery failure go to dealer message , as I m 2000 miles from the nearest service center ( France ) , the car don't want to start , I can only go to neutral , is there a solution hard or soft reset that I can do myself ? Thanks
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #2 ·
I have hard booted the car and now all went black no electricity at all , key fob not working , dash board off etc... Please help
Thanks
 

·
Premium Member
Joined
·
3,077 Posts
See if you apply a 12 volt source using another car with jumper cables if the car will wake up . Positive leed in the fuse box which is near the left front headlamp under the hood .open the lid there is a small stud with threads sticking up that's positive .

Negative you can use the module near the fire wall that has the red cover which is also positive . Use the big black wire with the 14mm bolt head as ground .

Just so you know your not the only Karma in Africa I have two others there .
One in Senagel and the other in Angola Luanda
 

·
Premium Member
Joined
·
484 Posts
Harleyguy, After reading all the problems when the 12 volt battery goes bad, doesn't it make sense to first just replace replace the battery since they are so cheap? and then go from there? Seems like it would save hours of troubleshooting. Please chime in if i'm wrong.
 

·
Premium Member
Joined
·
3,077 Posts
Harleyguy, After reading all the problems when the 12 volt battery goes bad, doesn't it make sense to first just replace replace the battery since they are so cheap? and then go from there? Seems like it would save hours of troubleshooting. Please chime in if i'm wrong.
I agree about replacing the battery but understand one thing . Not everyone has the tools to replace it .You a floor jack have to remove the tire remove the inner wheel well arch . Then fit to get the battery out which in itself isn't to light . Not sure if you ever seen where the battery is located trust me it's not a bad job and I've changed plenty of them plus a few without a lift .

If someone can get the battery too take a charge and the battery holds a charge no reason to have to replace it . Also you have to remove the battery first and go to the local parts store and hope they have one that matches the original one and I mean one that just doesn't fit but meets the requirements like CCA
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #7 ·
Hi guys
I have tried with 12 volt , the dash board wakes up during 30 secs and after sleeps again , impossible to start the car , I have checked if there was energy from the positive leed and there is energy , please advise what you recommend to do now , flatbed the car to France ?
Many thanks in advance
 

·
Premium Member
Joined
·
3,077 Posts
Hi guys
I have tried with 12 volt , the dash board wakes up during 30 secs and after sleeps again , impossible to start the car , I have checked if there was energy from the positive leed and there is energy , please advise what you recommend to do now , flatbed the car to France ?
Many thanks in advance
Is the ready light flashing ? How did you try the 12 volt did you try another battery or jumper cables ? Sounds stupid did you have the key inside the car does the touch screen come on . Seems your leaving something out of the story .When you put the car in ACC mode yellow light on the start stop switch what happens?
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #9 ·
I have used cables with a 12 volt battery , The ready light works for 30 secs , the key is with me inside the car , no touch screen , the start stop button doesn't light on any color .
Another thing : day one when the message came there was no range on the electricity battery and half tank on the gas indicator , now that the car has been hard booted , during the 30 secs that the dashboard works gas tank indicator shows empty and the electricity one shows 20 % range ... Thank you
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #10 ·
HI HARLEYGUY AND ALL ,
I HAVE REMOVED THE 12 v BATTERY AND CHECKED IT , ITS OK .
ONCE I HAVE INSTALLLED IT AGAIN DASHBOARD AND KEY FOB WORKED AGAIN BUT I STILL HAVE THE SAME MESSAGE ABOUT HIGH VOLTAGE BATTERY GO TO DEALER AND I CANT PUT DRIVE ONLY P AND N , PLEASE TELL ME WHAT YOU RECOMMEND ME TO DO MANY THANKS IN ADVANCE FOR YOUR HELP
 

·
Premium Member
Joined
·
1,975 Posts
Did you let the battery charger stay on for a couple minutes? What I noticed with one of my Karmas is that it might take a little while to provide enough juice to activate the HV battery to put the car into Ready mode.
 
1 - 11 of 11 Posts
Top