Fisker Buzz Forums banner
1 - 6 of 6 Posts

·
Signature Edition #99
Joined
·
12 Posts
Discussion Starter · #1 ·
Hi Guys,

Since about 2 months now the instrument cluster went blank. I have been using the car mostly on Petrol for a while without charging the battery and on the day it happend I was fiddling around with the headlights for the first time. What was I thinking ..!

There are similar posts with different suggestions; hard reset, soft reset and even one replacing the instrument cluster. I do not see other posts where the instrument cluster goes completely blank. With other patients the cluster seems to show a few symbols or works when the headlights are switched on.

The car is now at the dealers... I live in Dubai and we are lucky to have a service dealer. But they are now suggesting to replace the unit... which is going to hurt if the part is even available. Any suggestions?

I tried fully charging the car (had a problem with the cable earlier) and performed a hard reset, soft reset and all resulted with no change.

Any comment/suggestion is welcome.... thanks!
 

·
Registered
Joined
·
1,091 Posts
Yes, I've replaced quite a few actually, from faulty video monitors to mother boards failing. Unfortunately replacing is the only option. Make sure they follow the 0rocess to pull the old data from the original cluster before swapping in the new one. Your mileage is burned into the memory and needs to be written into the new one.
 

·
Premium Member
Joined
·
3,077 Posts
Your looking at least $1650.00 for just the instrument cluster and in Fisker time guide to remove the topper panel that's what they call the top dash panel it pays 9.0 Hours .It doesn't take that long to R/R it but that's what is in the time guide .
 
1 - 6 of 6 Posts
Top