Fisker Buzz Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
141 Posts
Discussion Starter · #1 ·
I had an episode described by others where I put the car into drive and when I started moving it made a horrific grinding noise. When I looked down, the pawl had not engaged into D although the car was moving.

I took it in and alas, 3 weeks later, I have the car back. They had to replace the entire REAR DIFFERENTIAL (as they told me- a 1400 lb part that took 2 weeks to get from Finland) and basically replaced the entire rear of the car...

bdo
 

·
Premium Member
Joined
·
1,975 Posts
1,400lbs sounds high for that... I think Nimsys said the diff and motors were around half that weight...

Does your dealer have any idea what was the cause?
 

·
Registered
Joined
·
141 Posts
Discussion Starter · #4 ·
It started when I was on a hill and put the car into D and it moved but the PAWL did not progress and it ground away making an awful sound. Fisker said take it in and it was a danger. The car also wouldnt move earlier in the day in which I couldnt get it into D.

The order sheet I got back says RDC replaced and a bunch of seals were re-done to the correct size.

Now the problem is that I was driving the car today and when I go from >60mph and rapidly slow down with by putting the car into HILL 2, I get a thunk thunk thunk sound that is about 5 clicks and then it goes away. Worrisome, but it doesnt impede the car or cause any problems. Also I think I'm imagining it, but the car doesnt seem as quiet to me in stealth as it was before...anyone else experienced either of these issues?[hr]
Here is what was done. If someone can decipher....









bigdaddyo811 said:
It started when I was on a hill and put the car into D and it moved but the PAWL did not progress and it ground away making an awful sound. Fisker said take it in and it was a danger. The car also wouldnt move earlier in the day in which I couldnt get it into D.

The order sheet I got back says RDC replaced and a bunch of seals were re-done to the correct size.

Now the problem is that I was driving the car today and when I go from >60mph and rapidly slow down with by putting the car into HILL 2, I get a thunk thunk thunk sound that is about 5 clicks and then it goes away. Worrisome, but it doesnt impede the car or cause any problems. Also I think I'm imagining it, but the car doesnt seem as quiet to me in stealth as it was before...anyone else experienced either of these issues?
 
1 - 4 of 4 Posts
Top