Fisker Buzz Forums banner
1 - 1 of 1 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
Hello Folks,
I have been hit with my Karma not charging the HV battery. I have done some investigative work and also talked with Lormax and Harleyguy, both an incredible help. As I have only found very little information on my exact problem from the forums, I'm hoping this thread will help others that run into this issue as well as myself. Here is the issue. The HV battery stopped charging and I only run on ICE. The battery stills show about 10% left. Charging via 120 and multiple different 240's receive the same failure. The check engine light stays on. When you try to charge it, I do hear the relay clicks go off, my charger blinks like it is charging for about 5-10 seconds, and then stops as well as more clicks, but the charging light on the dash does stay lit (I do believe this eliminates the issue that it may be the $2000 internal charger behind the bumper??). My Walmart of OBDII/CAN readers does show: FAULT:02 PEND:01 with 3 screens N/A 01/02/03, so I do not think this is of much help. If anyone has the special Fisker Karma service laptop that can read all codes and would allow me to borrow it for a cost, I would appreciate it. I do believe the problem is the Tyco relay in module #5 . So, I'm looking at if anyone has replaced this and they have detailed directions on how to fix this myself. First, I tried to find the Tyco part number but the only part I found is the 350 Amp Tyco MSD plug assembly (in the bankruptcy notices):
http://www.te.com/catalog/pn/en/1-2103172-1
If anyone could offer up the exact Tyco part number for this relay module, I would appreciate.
Next I ask kindly for any detailed directions on how to remove the battery and other necessary steps (You tube video?). A great start is the high voltage Fisker safety guide located here:

http://d239dpbe52lm4w.cloudfront.ne...d_High_Voltage_Safety_materials_with_Card.pdf

I will obtain the High voltage gloves and required tools, as it may be very easy to perish when touching the 400Amp/400 Volt cable, connections and battery. Next, one would need a lift as well as another engine/transmission stand to hold and drop the battery from the Karma, luckily I think I have this arranged.
Lastly a few other questions - would not charging the HV battery be deadly in the long run, meaning it may kill the cells or something of that nature and cause the need to replace the whole $20k battery if it is not charged? Any HV battery experts in the phoenix area or possibly an old A123 Battery systems tech that would like some work? Seeing catastrophic failures happen (not able to run on Stealth) and lack of local maintenance and support brings me to the point that technical and proficient Karma owners could use even more information on being able to fix their Karmas by themselves. I'm hoping this thread can assist other owners as well as myself. Thanks for any assistance in advance.
 
1 - 1 of 1 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top