Fisker Buzz Forums banner
1 - 7 of 7 Posts

·
Premium Member
Joined
·
44 Posts
Discussion Starter · #1 ·
Drove my Karma a couple of miles from home to get frozen yogurt for my kids, got in it to go home and the fan kept kicking on as if I was running the a/c which I wasn't. So I restarted it 2 times and everything turned red with warnings saying immediately get to a service center and all of the miles in the range counted down backwards to what was left on the batteries (41 Mi) but in red. I drove home and it would not go into hill mode at all on the way home just stealth. I can't find anything related to the Qdrive in my manual and it was a limp fault 01. I am 2 hours from the closest dealer. Can anyone give me advise???
Thanks!
 

·
Registered
Joined
·
1,115 Posts
Not much you can do yourself there but try hard reset of 12v battery and hope it changes something otherwise it is an HV fault most likely within battery or related modules. Would need to go in to the dealer. Id offer my help but I'm a bit more than a couple hours...
 

·
Premium Member
Joined
·
44 Posts
Discussion Starter · #3 ·
Thank you! I will try to do a hard reset. I will call my dealer first.
I appreciate your response!
 

·
Registered
Joined
·
28 Posts
I have the kind same problem you have does your car been fixed and how much you pay? My dealer told me fisker website is down again they cant diagnosed it now I have to wait and wait .
 

·
Registered
Joined
·
8 Posts
I also have the same problem. Hard reset and was able to get by for a week. Will ned to get it to the dealer. please Let me know what to expect from dealer.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top