Fisker Buzz Forums banner
1 - 13 of 13 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
I'm excited about my Karma. Hasn't been a month yet and having a few problems but I still love it. I decided to join after reading so much great information on here.

I've been dealing with Lormax on some parts so I hope to have it back running soon.

2012 Silver Wind EcoChic - Glacier Tri-Tone #0187
 

·
Premium Member
Joined
·
4,662 Posts
I'm excited about my Karma. Hasn't been a month yet and having a few problems but I still love it. I decided to join after reading so much great information on here.

I've been dealing with Lormax on some parts so I hope to have it back running soon.

2012 Silver Wind EcoChic - Glacier Tri-Tone #0187
Welcome to the forum and hope that the problems are resolved swiftly and you get to enjoy your Karma very soon.
 

·
Registered
Joined
·
52 Posts
Hi. My blue Karma and I live in Cary, NC, if you ever come by, stop by.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #7 ·
I was told its a worn coupler issue. I kept getting the reduced performance and check engine lights along with multiple misfire codes.
 

·
Registered
Joined
·
1,091 Posts
Assuming your sw is latest 510? There are still some misfire issues that havent been fully resolved and FA was still working on refining the sw. Most of the time its a conflict between commanded generator load and engine. For instance if battery is fully charged and ICE is commanded on to run OBD monitor tests the ECM commands the GEN to load the engine to test emissions components such as O2 sensors or catalyst. This simulates driving a conventional gas vehicle under load or highway situation. The only way to load the engine is to charge the HV battery. However if the battery is fully charged it caused the generator to run out of phase and oscillates the crankshaft of the ICE thus triggering what the ECM interprets as a misfire. Its actually just the crank slowing and speeding up not an actual misfire. Similar to the feeling you get when you feel the rear motors phase when you roll slowly.
I know that was alot of blah blah but I felt it was worth the explanation as I get alot of questions about misfire codes.

In addition a worn coupler will make an excruciating noise.
 

·
Registered
Joined
·
120 Posts
Just popping in to say howdy. I'm in western NC, and just picked up my Karma yesterday (6/19/14)!

Mine's an EcoSport Eclipse
 

·
Registered
Joined
·
888 Posts
Also congrats from Germany!
Do you have any photos available?
 
1 - 13 of 13 Posts
Top