Fisker Buzz Forums banner

21 - 22 of 22 Posts

·
Registered
Joined
·
781 Posts
pactoll said:
I have had my car now for about a month now and I also cannot get my radio presets to hold. I think the radio is losing power when you turn the car off which clears the radio everytime.
This seems to be a common problem. I've had it zap my radio presets 3 times now.

-Brian
 

·
Premium Member
Joined
·
1,975 Posts
pactoll said:
MartySmith361 said:
Love mine. Century sent a flatbed and loaner 7-series for me to drive while the battery was replaced. Got it back in a few days all cleaned up. Had my charging station installed by that time. The ride is sweet, especially on Stealth mode. It feels like it is gliding. The audio is amazing but I enjoy driving with it off to get the full effect of the all electric ride. Very responsive and quick in traffic. Most of my driving can be done in a day on a single charge. I haven't had any major issues, software or otherwise. Still trying to figure out how to get Sirius Radio to hold presets. Must be something simple. Be prepared to spend a lot of time explaining what it is.
I have had my car now for about a month now and I also cannot get my radio presets to hold. I think the radio is losing power when you turn the car off which clears the radio everytime.
Have had car three days and no problem with presets. Have had a couple flukes with Bluetooth audio and the quality of te sound on Bluetooth phone calls is terrible - tons of static.
 
21 - 22 of 22 Posts
Top