Fisker Buzz Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I'm an original Karma owner (Eco Sport Inferno Red) having put my deposit down in 2008 and received delivery in May 2012.

I enjoyed driving the car and have used it for my daily commuting and now have 25,550 miles on it.

Most issues were resolved with software patches in the first few months, and I've lived with a number of minor issues since. Of the "250", I've probably experienced less than 10.

I appear to have my first major issue as the battery won't charge any longer. It goes into charging mode and clicks back off about 10 seconds later. I've been reading through the forums and see there could be a few different issues.

I use a 240V GE charger at home at use the 120V that came with the care at the office. I will be testing again with the 120V charger but suspect it was connected to that charger when it stopped working, so I will also try a public charging station.

Lifetime average fuel economy has probably been in the 120-145 mpg range - which I fully appreciate.
 

·
Registered
Joined
·
334 Posts
Welcome @Jeff_NC! As a recent owner, it's great to hear from a long term owner like yourself that is up to 25K miles.

Sorry to hear you're having a problem but it's good that you joined the Forums as they are a tremendous source of information and help. Your issue definitely sounds similar to other issues owners have experienced here. The good news is guys like @Harleyguy (in FL) and @FiskerPhilly (in PA) should be able to help you.

Good luck.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top