Fisker Buzz Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
81 Posts
Discussion Starter · #1 ·
For about 2 months now, my driver's door touch pad inside and out only works about 50% of the time and for the last week it won't work at all. What a major inconvenience, and embarrassment, as I have to open the passenger door and reach across to pull the emergency pull ring every time I need to get in my car. I took apart the door panel and pulled some of the wires off and back in the harnesses, and it worked for a few days after that, 100% of the time, so I can only assume there is a short somewhere unless it was just a coincidence. Tampa Fisker hasn't been able to take my car in for service for over a year now so I think I am done with them. PLEASE HELP!!
 

·
Premium Member
Joined
·
4,662 Posts
I took apart the door panel and pulled some of the wires off and back in the harnesses, and it worked for a few days after that, 100% of the time, so I can only assume there is a short somewhere unless it was just a coincidence. Tampa Fisker hasn't been able to take my car in for service for over a year now so I think I am done with them. PLEASE HELP!!
This is just a guess, but if messing with the harness fixed it, albeit temporarily, it seems like it is a connection problem, not a short. Can you tell if the connectors are making solid contact? Maybe one of the pins is bent or pushed in and making intermittent contact? Just going off my usual electrical system debugging protocol.
 

·
Registered
Joined
·
81 Posts
Discussion Starter · #3 ·
Thanks Fab. I do not believe it is any harness now, because sometimes when you hit the inside or outside pad to unlock, you can hear, what I believe to be, a motor trying to open the door. It's a slight sound that will work maybe once or twice, then there is no sound for a while. It's very odd. So the pads quit entirely since my last post. I did figure out a temp solution by holding the unlock button on my remote and the windows roll down, so it's much easier to pull the emergency cord every time instead of climbing through the car to get to it. And now the door is working every time! So before it drives me crazy, is this motor sound I hear a posible bad motor I can replace and if not replace because parts are not available, maybe I can at least swap it with one o the back motors?? Thanks so much for any help.
 
1 - 3 of 3 Posts
Top