Fisker Buzz Forums banner
1 - 16 of 16 Posts

·
Registered
Joined
·
192 Posts
Discussion Starter · #1 ·
For a month or so now I'm experiencing a delay when selecting "D". P, R, & N are usually within a second, but when I select D there is a delay from 2 -10 seconds. I don't mind 2 seconds, but after backing out from parking at the mall, traffic gets impatient if I block the thruway for 10 seconds. I've tried a hard reset, to no avail. Anyone else have this? Cure?
 

·
Fisker R&D and Build Tech
Joined
·
35 Posts
Do you hear a noise on deceleration? It will likely be heard at lower speeds. Grinding maybe. There can be several reasons for the delay, but the most common is the C clip in the RDM came out of place and the park gear rides against the pawl actuator.
 

·
Premium Member
Joined
·
3,077 Posts
Even is he wasn't on 510 that wouldn't make a difference checking for stored fault codes is the way to start and yes the PRD could be the problem
 

·
Registered
Joined
·
996 Posts
For some cars on 614 you would have to select N before selecting D (as well as the dreaded PRND fault) I wanted to make sure he was on the latest firmware and not 614/615.

You could also try the DNRP method and see if that works. Basically put the car in ready mode and hit D with foot on brake for 3 secs and continue till you hit P, put the car to sleep and see if that clears the problem.
 

·
Registered
Joined
·
483 Posts
For some cars on 614 you would have to select N before selecting D (as well as the dreaded PRND fault) I wanted to make sure he was on the latest firmware and not 614/615.

You could also try the DNRP method and see if that works. Basically put the car in ready mode and hit D with foot on brake for 3 secs and continue till you hit P, put the car to sleep and see if that clears the problem.
completely different issues. If he was on an older software and did not select Neutral once every 10 key cycles it would cause a PRND fault, not a delay in shifting.
 

·
Premium Member
Joined
·
4,662 Posts
For a month or so now I'm experiencing a delay when selecting "D". P, R, & N are usually within a second, but when I select D there is a delay from 2 -10 seconds. I don't mind 2 seconds, but after backing out from parking at the mall, traffic gets impatient if I block the thruway for 10 seconds. I've tried a hard reset, to no avail. Anyone else have this? Cure?
Until you find a solution, maybe you should back your car into the parking spots at the mall, etc. That way, you don't have to do a shift in mid-maneuver when you park or when you exit the parking spot.
 

·
Registered
Joined
·
854 Posts
Until you find a solution, maybe you should back your car into the parking spots at the mall, etc. That way, you don't have to do a shift in mid-maneuver when you park or when you exit the parking spot.
That's an excellent suggestion. Holding up traffic in the parking lot sounds embarrassing.
 

·
Registered
Joined
·
192 Posts
Discussion Starter · #11 ·
Yes, I'm on 510. Yes, I do back into parking slots, when feasible. Yes, I've tried DRNP and sleep. Yes it still has the delay.
 

·
Registered
Joined
·
536 Posts
I think backing in is just the way to go anyway (if it's feasible/no charging station conflict), because otherwise it's only a matter of time until you mash up the front bumper cover (which you may not be able to even get a part to fix).
 

·
Registered
Joined
·
996 Posts
Yes, I'm on 510. Yes, I do back into parking slots, when feasible. Yes, I've tried DRNP and sleep. Yes it still has the delay.

So there is no change if you go from P->N->D / R->N->D vs P to D? You may want to explore replacing the shift pyramid. It is pretty straight forward to replace.
 

·
Registered
Joined
·
192 Posts
Discussion Starter · #14 ·
Usually, the delay shows up going from R to D after driving somewhere. I have no problem when initially going from P to R to exit my garage.
 

·
Registered
Joined
·
996 Posts
Usually, the delay shows up going from R to D after driving somewhere. I have no problem when initially going from P to R to exit my garage.

Have you tried to go R->N->D? or R->P->D? Do you hear the chime still when shifting or is there no confirmation that "D" has been selected?
 

·
Registered
Joined
·
192 Posts
Discussion Starter · #16 ·
I've tried R-P-D, not R-N-D. That usually works. Probably any combo would work after trying D unsuccessfully. The chime works okay.
 
1 - 16 of 16 Posts
Top