Fisker Buzz Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
913 Posts
Discussion Starter · #1 ·
So far I have observed the following (and as far as I know I have the latest software)...
  • stuck on Fisker logo, never gets to accept, 2 minute power off reset style reboot fixes this (occurred once so far)
  • several letters in the word "STEALTH MODE" in system status garbled (looks like font overwrite; occurred once so far)
  • iPod not recognized as iPod (just shows as USB) - unplug/reconnect does not fix, but OK after 2 minute power off (occurred several times so far)
  • artwork sometimes does not show even when iPod recognized - pause (and wait a few seconds) usually fixes (occurs somewhat regularly)
  • artwork and info on current song fails to advance when changing tracks - pause and wait fixes - advancing one more song causes info to advance to previous song (!) (occurs somewhat regularly)
  • brief sound glitch (as though some data transfer lost) when playing iPod (occurs somewhat regularly)
  • if cell phone is bluetooth-connected to Samsung headset (i.e., I forget to turn off or remove headset before getting into car), it can't be connected to the Karma (this may be fixed by taking phone out of range and back, or maybe it was a 2 minute power off reset)
  • the nav system's idea of the speed limit is wildly wrong on parts of I-15
I haven't been able to program in a destination on the navigation system yet, but I may just not be doing it right, the interface is wretched. I prefer just using Google Navigation on the Android phone, except for its own buglet with bluetooth audio (the turn by turn directions activate the bluetooth connection but begin speaking immediately, and it takes roughly half a second to negotiate—this problem is in way Google Nav uses the Android system, and occurs with the Samsung headset too).
 

·
Registered
Joined
·
223 Posts
I've also experienced the "stuck on fisker logo" and variants of the graphics glitches and audio control bugs you mentioned. I'm running the current firmware (6.28).
 

·
Early Adopter
Joined
·
1,259 Posts
I have 6.28 and the command center is still a "work-in-progress".

backup camera blank screen at times
slow commnad selection and sometimes it works fine
nav just plain needs to be updated to something more use friendly
crackling with the phone "when" it connect -- a KIA I rented works better
BT music does not work all the time

I assume these items are being worked, would be nice to get an idea when they think they can get it resolved - I hate to see Fisker suffer the slings and arrows, but if we early adopter do not voice our experinces, then fisker will not solve the problems. Some creature conforts are expected when once drives such a wonderful piece of art.
 
1 - 3 of 3 Posts
Top