Fisker Buzz Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
This forum is great and I thank all of the knowledgeable people here providing useful information.

I have owned my beautiful Fisker for over a year. It has been a great car in so many ways. I had some minor repairs completed to front and rear bumper. The bumpers were removed, repaired and replaced. After I turned the vehicle back on everything operated as it should, but the CIU would not boot up. All that came up was the Fisker logo. I went thru the steps to do a hard reset to no avail - the logo remained without the CIU finishing it's boot up.

My baby is now at the only Fisker dealer still working on Fisker vehicles in the area and they are waiting on a response from Fisker Automotive to figure out what is wrong. We know about the leaking issues - this car was always garage kept and hand washed..... there are no signs of any water damage whatsoever.

If anyone has had a similar problem or can point me in the direction of someone with the knowledge to assist the tech in repairing this - I would truly appreciate it!!
 

·
Early Adopter
Joined
·
1,255 Posts
This forum is great and I thank all of the knowledgeable people here providing useful information.

I have owned my beautiful Fisker for over a year. It has been a great car in so many ways. I had some minor repairs completed to front and rear bumper. The bumpers were removed, repaired and replaced. After I turned the vehicle back on everything operated as it should, but the CIU would not boot up. All that came up was the Fisker logo. I went thru the steps to do a hard reset to no avail - the logo remained without the CIU finishing it's boot up.

My baby is now at the only Fisker dealer still working on Fisker vehicles in the area and they are waiting on a response from Fisker Automotive to figure out what is wrong. We know about the leaking issues - this car was always garage kept and hand washed..... there are no signs of any water damage whatsoever.

If anyone has had a similar problem or can point me in the direction of someone with the knowledge to assist the tech in repairing this - I would truly appreciate it!!
reach out to harleyguy and fiskerphilly -- i'm sure they can help you -- where do you live?
 

·
Premium Member
Joined
·
3,063 Posts
If you have no signs of water damage the CIU will need to be replaced . I was going to suggest a hard reset but if you all ready tried that then the CIU is done . One last thing the dealer can try is reloading 510 it's a last ditch effort but doesn't hurt to try .

Lucky for you Fisker has plenty of CIU on hand and the car has warranty .
 
1 - 3 of 3 Posts
Top