Fisker Buzz Forums banner
1 - 8 of 8 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I love my earth ecochic

Had it 2 months and put 2000 miles on it.

Sent it to shop 3 weeks ago for 615 upgrade for normal bugs.

Installation of update caused car to not charge.

Finally got new batteries installed 5-9-12 and it still will not charge

Dealer is stumped.

Has anyone had problems like this after firmware update?
 

·
Premium Member
Joined
·
4,662 Posts
EarthalcanteraNashville said:
I love my earth ecochic

Had it 2 months and put 2000 miles on it.

Sent it to shop 3 weeks ago for 615 upgrade for normal bugs.

Installation of update caused car to not charge.

Finally got new batteries installed 5-9-12 and it still will not charge

Dealer is stumped.

Has anyone had problems like this after firmware update?
I think someone had this problem and it turned out to be the on-board charger that was defective. Have they checked that out?
 

·
Registered
Joined
·
18 Posts
If the dealer is stumped they might want to ask Fisker Corporate to send out a field technical specialist. Or someone at corporate can talk to your dealer's technician over the phone and tell them what tests to perform beyond the ones described in the repair manual.

There is a fix for your car, they just haven't found it yet.
 

·
Premium Member
Joined
·
3,077 Posts
Very hard to believe they are stumped Fisker has plenty of tech support unless the tech isn't explaining the problem correctly to tech support they may have him looking in the wrong direction . It's very important that from the service writer right down the line the customers problem is explained to the tech correctly . I've found one of the key component in repairing any make car is good old communication between all parties involved . Most of the times if not all of the times when a Karma is dropped off for service I meet with the customer and review all the complaints they have and ask the customer plenty of questions just to make sure were both on the same page .
 

·
Registered
Joined
·
74 Posts
My car has also quite charging but im still on 6.14.5....dealer was so backed up, by the time they had a slot open, the car had completely gone dead & would not move, shortly after, the 12v went completely dead, had to be yanked out of the garage by a tow truck, wheels on skates, (no way to get it in park when dead) took him over 2 hrs to get it on the truck....was a nightmare, third time to the shop in 90 days since purchase, my patience is wearing very thin at this point.
 
1 - 8 of 8 Posts
Top