Fisker Buzz Forums - View Single Post - Introduction & a question
Fisker Buzz Forums

View Single Post
Old 01-12-2021, 03:07 AM   #4 (permalink)
SirCastic
Member
 
Join Date: Oct 2018
Location: Southern Sweden
Posts: 85
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 18 Post(s)
Default

Quote:
Originally Posted by CHFisker View Post
Thank you. This is very helpful. Remarkably detailed video series. I don't think I'm capable of doing this myself but it helps verify the issue and give an idea of where it might go.

Also, I had read that the lack of heating was just how it was and one simply put it into sport mode and then switched back so the car would heat up. I will look into the heater. That's a bonus learning.
Hello in Switzerland!
I have really nice heat driving in stealth mode without engaging sport mode (I also like the idea that the ICE starts up preheated to prevent unnecessary wear during cold starts).

Your PTC heater pump is probably out of order, I would also suggest checking out your electric PTC coolant fluid heater (located underneath the center coolant tank) and the fuse (located under the HV battery).

Wait for car to be cold overnight and start the car in stealth mode… heat to max. Now feel if there is any heat radiating from the rubber hoses underneath the center coolant tank. Your electric PTC coolant fluid heater is high voltage and dangerous, be careful with the power connections and fuse.

Best regards from Sweden!
Attached Images
File Type: jpg unnamed.jpg (29.3 KB, 4 views)
SirCastic is offline   Reply With Quote
 
Powered by vBadvanced CMPS v3.2.3

All times are GMT -4. The time now is 08:37 PM.



Powered by vBulletin® Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.