Fisker Buzz Forums - View Single Post - Karma 2012 not charging from 240v plug
Fisker Buzz Forums

View Single Post
Old 06-16-2020, 07:33 AM   #4 (permalink)
Harleyguy
Senior Member
 
Join Date: Mar 2012
Location: South Florida
Posts: 3,014
Mentioned: 146 Post(s)
Tagged: 3 Thread(s)
Quoted: 495 Post(s)
Default

Quote:
Originally Posted by metallio View Post
I don't think it's the obcm since i've tried with the fast charging station but the result is the same, do you perhaps know which one of the 5 contactors is the one to switch? It seems like the EDM has already been opened by someone else before, there were marks on screws and nuts most likely a contactor has been changed in the past already, is it so common for these contactors to fail?
Just because the contactor was replaced before doesnt mean it can fail again. Ive replaced the number 5 contactor numerous times after they been replaced. You also need to separate the contactors in order to properly check them. If the check engine light is on and you hear the relays clunk when you plug the car in and after a few seconds you hear them clunk again I would replace the contactor . And never rule out the OBCM they also have a failure problem .
Harleyguy is offline   Reply With Quote
 
Powered by vBadvanced CMPS v3.2.3

All times are GMT -4. The time now is 04:10 PM.



Powered by vBulletin® Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.