TOM Module Upgrade - Page 11 - Fisker Buzz Forums
Fisker Buzz Forums

User Tag List
PowerSource

Reply
 
LinkBack Thread Tools
Old 01-11-2020, 09:04 PM   #101 (permalink)
Junior Member
 
Join Date: Feb 2019
Posts: 12
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Default Successful partial regression to 520

Quote:
Originally Posted by Arpie View Post
Update: Ken at PwrSource did get back to me so I now have the info I need.
After more than I month I have my Karma back and I have to thank Ken and Luc at Powersource for their incredible support and guidance. Joe Ferrante was also great and provided confidence in the ultimate solution which I think is worth sharing.

The issue I had is that shortly after installing the TOM my local (Karma) technician upgraded the systems to 535 without me taking notice. After a period of time I became aware that the odometer was over clocking at a rate of nearly 8/1. When I took it int the dealer, the TOM was identified as the culprit, and after circling back with Powersource the change “upgraded” software was confirmed to be the cause. The 535 software contains new algorithms for calculating speed and distance which is what makes it incompatible with the TOM. In BL520 the HCU uses signal from the ECM to calculate speed whereas in BL535 the HCU uses wheel speed signals to calculate speed.

If I wanted to continue to take advantage of the TOM (and I did) I needed to do at least a partial reversion back to 520 that included 3 (ECM, HCU and BECM) of the 9 control modules. Unfortunately the Karma tech only had access to the 520 files for the HCU and the BECM, so again we were stuck.

Two possible options through the road block were to get on the waiting list for a scan tool with the full 520 reversion or to remove the ECM from my car, send it to Joe in Philadelphia so he could flash it to 520 and send it back for reinstall. A third alternative I came up with was to purchase a used ECM that likely hadn’t been upgraded to BL535 and try that. We purchased the used one and it worked - problem solved.

Everything now seems to be fine. The car has BL535 on the EBMC, DIS, TM1, TM2 and GEN with BL520 on the ECM, HCU and BECM. Thanks again everyone.
Arpie is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Powersource TOM calculations jomak Fisker Karma 29 06-28-2016 04:31 PM
TOM where did you go? jomak Fisker Karma 1 06-12-2016 07:17 PM
TOM for 2012 Karma Stefan Fisker Karma 12 05-13-2016 08:56 AM
Module Update PowerSource Fisker Karma 12 10-28-2015 02:14 AM
Tom Lasorda on production numbers, profitability and the DOE loan dennis The Fisker Lounge 4 02-29-2012 08:58 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -4. The time now is 03:38 PM.



Powered by vBulletin® Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0 PL2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.