Karma 2012 not charging from 240v plug - Fisker Buzz Forums
Fisker Buzz Forums

User Tag List

Reply
 
LinkBack Thread Tools
Old 06-15-2020, 10:37 AM   #1 (permalink)
Junior Member
 
Join Date: Jun 2020
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Default Karma 2012 not charging from 240v plug

Hello, I'm a car electronic technichan and currently have a fisker karma my2012 in my garage that's not charging, when i plug it in it starts charging and then 10 seconds later stops, you can hear the click, i've already took off the HV battery, and testing the contactors on bench they click and turn to 2 ohm, is the problem on this contactors related to current? (not bringing enough current?)
or maybe can be something else?
Anyway i have one error related, it's:

P0A7B

but with the instruments i have i can only do eobd connection, is there a specific instrument to do a full diagnosis on these cars?

Thanks
metallio is offline   Reply With Quote
Old 06-15-2020, 09:38 PM   #2 (permalink)
Member
 
Join Date: Oct 2018
Location: Southern Sweden
Posts: 82
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 18 Post(s)
Default

Quote:
Originally Posted by metallio View Post
Hello, I'm a car electronic technichan and currently have a fisker karma my2012 in my garage that's not charging, when i plug it in it starts charging and then 10 seconds later stops, you can hear the click, i've already took off the HV battery, and testing the contactors on bench they click and turn to 2 ohm, is the problem on this contactors related to current? (not bringing enough current?)
or maybe can be something else?
Anyway i have one error related, it's:

P0A7B

but with the instruments i have i can only do eobd connection, is there a specific instrument to do a full diagnosis on these cars?

Thanks

No 5 contactor most likely.

Cod P0A7B, BECM is requesting MIL and that code should be followed by another code that pinpoints the problem.

Only Fisker Karma WDI (Prodis) can perform a full diagnosis.

Try to charge at a public ChargePoint station (to rule out a faulty 240 volt charger).
SirCastic is offline   Reply With Quote
Old 06-16-2020, 05:32 AM   #3 (permalink)
Junior Member
 
Join Date: Jun 2020
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Default

I don't think it's the obcm since i've tried with the fast charging station but the result is the same, do you perhaps know which one of the 5 contactors is the one to switch? It seems like the EDM has already been opened by someone else before, there were marks on screws and nuts most likely a contactor has been changed in the past already, is it so common for these contactors to fail?
metallio is offline   Reply With Quote
 
Old 06-16-2020, 08:33 AM   #4 (permalink)
Senior Member
 
Join Date: Mar 2012
Location: South Florida
Posts: 3,043
Mentioned: 149 Post(s)
Tagged: 3 Thread(s)
Quoted: 504 Post(s)
Default

Quote:
Originally Posted by metallio View Post
I don't think it's the obcm since i've tried with the fast charging station but the result is the same, do you perhaps know which one of the 5 contactors is the one to switch? It seems like the EDM has already been opened by someone else before, there were marks on screws and nuts most likely a contactor has been changed in the past already, is it so common for these contactors to fail?
Just because the contactor was replaced before doesnt mean it can fail again. Ive replaced the number 5 contactor numerous times after they been replaced. You also need to separate the contactors in order to properly check them. If the check engine light is on and you hear the relays clunk when you plug the car in and after a few seconds you hear them clunk again I would replace the contactor . And never rule out the OBCM they also have a failure problem .
Harleyguy is offline   Reply With Quote
Old 06-16-2020, 09:30 AM   #5 (permalink)
Junior Member
 
Join Date: Jun 2020
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Default

Yes, since i've the hv battery on bench it makes sense to change the contactor, can you tell me which is te n.5? or would you guys suggest to change them all?
metallio is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -4. The time now is 04:10 PM.



Powered by vBulletin® Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0 PL2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.