Fisker Buzz Forums

Fisker Buzz Forums

Fisker Buzz Forums (https://www.fiskerbuzz.com/forums/)
-   Fisker Karma (https://www.fiskerbuzz.com/forums/13-fisker-karma/)
-   -   Traction Control and White Gauge Cluster (https://www.fiskerbuzz.com/forums/13-fisker-karma/41233-traction-control-white-gauge-cluster.html)

TahoeKarma 05-23-2020 11:37 PM

Traction Control and White Gauge Cluster
 
I’m hoping to just run a few quick questions by the Fisker community. I was driving today and the ESC light flashed on at freeway speeds, but there didn’t seem to be any loss of traction. I could feel the function engaging... there was a slight “shimmy” in the steering. I turned off ESC and turned it back on - after about 5 minutes it did it again. This has happened one time before, with the only thing being in common is that it was a hot day. Has anyone had ESC randomly engage on hot days (or other times)? The other question I have is on the display cluster... I see videos online showing a white cluster, but mine is black with white and red “indicator” lights (speed, battery charge, etc). Do some Karmas just have white clusters and others don’t? Or am I missing a setting? Thanks in advance for any insights!!!

Discordian 06-04-2020 07:45 PM

Oddly enough my car is randomly turing on the ESC light for extended periods of time right now too. Never had a car go out of its way to tell me ESC is on before.

I'm not sure what it means, but tomorrow I'm having it inspected. If I find anything out, I'll let you know.

Discordian 06-06-2020 05:16 PM

So from what I understand now, the traction control "on" light can just be on for a couple of reasons.

Something in your alignment is off, something about the last time your alignment was done was wrong (adjustment and/or car program calibration to match), or it could be a bad sensor.

My case appears to be a bad sensor.

TahoeKarma 06-09-2020 06:19 PM

Makes sense! Thank you so much for responding with your findings... this helps. I now remember having it aligned when I put new tires on the shop said something about having trouble getting the alignment "perfect" with the 22 inch wheels. Looks like I'll need to take it in! Just out of curiosity, was the sensor an expensive fix for you?

Quote:

Originally Posted by Discordian (Post 328461)
So from what I understand now, the traction control "on" light can just be on for a couple of reasons.

Something in your alignment is off, something about the last time your alignment was done was wrong (adjustment and/or car program calibration to match), or it could be a bad sensor.

My case appears to be a bad sensor.


Discordian 06-09-2020 09:28 PM

The sensor is on order right now, didn't put a rush on it once we found out it wasn't something terrible.

I'll report back when I get a bill.


Since you live in Northern California you might want to reach out to Pat at https://www.patsgarage.com/. He might be able to help you out with the alignment thing.


All times are GMT -4. The time now is 05:29 PM.

Powered by vBulletin® Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0 PL2

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.

User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.

Powered by vBadvanced CMPS v3.2.3

All times are GMT -4. The time now is 05:29 PM.



Powered by vBulletin® Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0 PL2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.