Display gone - Speedometer etc. - Fisker Buzz Forums
Fisker Buzz Forums

User Tag List

Reply
 
LinkBack Thread Tools
Old 05-23-2014, 10:49 PM   #1 (permalink)
Junior Member
 
Join Date: Jul 2012
Posts: 13
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Garage
Default Display gone - Speedometer etc.

Hi there, love my Fisker but for the last month or so the display which shows my speed etc is gone, off, kaput. It seems the car is always "on" in that the dashboard screen NEVER turns off even when the car is off or charging. Any ideas?
David Feld is offline   Reply With Quote
Old 05-23-2014, 11:23 PM   #2 (permalink)
Super Moderator
 
Fabulist's Avatar
 
Join Date: Apr 2011
Location: San Francisco, CA
Posts: 4,105
Mentioned: 23 Post(s)
Tagged: 1 Thread(s)
Quoted: 226 Post(s)
Default

Quote:
Originally Posted by David Feld View Post
Hi there, love my Fisker but for the last month or so the display which shows my speed etc is gone, off, kaput. It seems the car is always "on" in that the dashboard screen NEVER turns off even when the car is off or charging. Any ideas?
Have you tried the obvious stuff, like triple-clicking the Start button to force the car to shut down, and the hard reset?
__________________
-- Fab.

Original owner of 2012 Eco Sport Black (Eclipse) with Monsoon Tritone Interior. VIN: -0641
Fabulist is offline   Reply With Quote
Old 05-24-2014, 07:22 PM   #3 (permalink)
Senior Member
 
Join Date: Nov 2011
Posts: 1,171
Mentioned: 23 Post(s)
Tagged: 1 Thread(s)
Quoted: 81 Post(s)
Default

So is it off or on? I'm a bit confused from the post. The car drives fine otherwise?
__________________
Factory Trained and Certified Fisker Tech, operating independently out of Southern California.

Owner of Fix The Karma LLC
http://www.fixthekarma.com
Lormax is offline   Reply With Quote
 
Old 05-25-2014, 02:52 PM   #4 (permalink)
Fisker Miami
 
Join Date: Mar 2012
Location: South Florida
Posts: 2,488
Mentioned: 88 Post(s)
Tagged: 2 Thread(s)
Quoted: 326 Post(s)
Default

If the car drives fine goes into ready mode and you have no other issues then the DIS aka the instrument cluster has gone bad . Fisker doesn't carry any I know that for a fact also if you install one from a salvage car what ever mileage that was on the salvage will be your new mileage . If you do get a used one I can check with Fisker if they can program the correct mileage .
__________________
Lamborghini Broward
Fisker Miami
apotter@warrenhenryauto.com
Harleyguy is offline   Reply With Quote
Old 05-25-2014, 09:11 PM   #5 (permalink)
Junior Member
 
Join Date: Jul 2012
Posts: 13
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Garage
Default

The car drives great (thank god) but (starting a month ago) I can never see any display for speedometer and/or engine light (if it's on which it likes to do once in a while). I can see the the mileage though, seems to be a slightly different display for mileage so that's unaffected. It's just the top part of the screen that seems off.

Also, to make this more confusing it feels like the car is always "on". Not green light start button on, but the dash display (the part that works) is always on even when the car is off.

For instance, right now if I go out to the car which is armed and charging for the last hour, and I look through the window, the battery/gas displays are on (normally ALL displays are off when the car is off) and I can see how much the battery is charging, how much gas is left etc. I can ALWAYS see this now because these displays never turn off. I feel like that whole thing just has to be reset, but don't know how.

I have tried using a triple click on the start button as mentioned in this thread but that didn't do anything (I was hoping it would but it didn't even seem to register a soft reset). I have not tried a hard reset yet.

So, my post is confusing because the car feels a bit "on" and a bit "off" all the time.

Really appreciate everyone's assistance and I feel like you guys might be able to help me!

Thanks!
David Feld is offline   Reply With Quote
Old 05-25-2014, 09:18 PM   #6 (permalink)
Senior Member
 
Join Date: Nov 2011
Posts: 1,171
Mentioned: 23 Post(s)
Tagged: 1 Thread(s)
Quoted: 81 Post(s)
Default

That makes a lot more sense, thank you.

I'd try a hard reset on it to see what happens. Is a dealer near you? If the hard reset doesn't help, you can have the dealer do a re-flash to the DIS (That module we're talking about). Unplug the charger before trying this though.
__________________
Factory Trained and Certified Fisker Tech, operating independently out of Southern California.

Owner of Fix The Karma LLC
http://www.fixthekarma.com
Lormax is offline   Reply With Quote
Old 05-25-2014, 09:23 PM   #7 (permalink)
Junior Member
 
Join Date: Jul 2012
Posts: 13
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Garage
Default

Thanks Lormax. I will try a hard reset (when its morning here so I don't piss off the neighbours when the alarm goes off). I have to find a good easy way to do the hard reset - I have never done it before.

I am in Toronto and the VW dealership that used to service my Fisker just told me their network to Fisker has been shut down and they cannot help me anymore at all until they get reconnected. Unfortunately, they don't know if that will ever happen - sad. Love this car, love you guys and want to keep it on the road.
David Feld is offline   Reply With Quote
Old 05-25-2014, 09:34 PM   #8 (permalink)
Senior Member
 
Join Date: Nov 2011
Posts: 1,171
Mentioned: 23 Post(s)
Tagged: 1 Thread(s)
Quoted: 81 Post(s)
Default

The alarm shouldn't go off actually. Unless there's a VCM issue, doing a hard reset has never set off the alarm for me. If it does, a quick push of the center button on the key fob will turn it off.

To do the hard reset, pop the hood then move around to the passenger side of the vehicle, right by the passenger side front tire. Look straight down, you'll see a large black connector directly above the tire. There may be a grey lock mechanism, which you can pull out with your fingers or a small flathead to pop loose. Once removing that, or if there isn't one, push down on the tab and pull the connector apart. It doesn't take a whole lot of force at all. Leave it disconnected for about 10 seconds, then plug it back in and turn the car on.

I advise leaving the key outside of the car during this, just in case. You'll need to re-calibrate the emergency brake (turn it on, then turn it back off). You may also need to re-cal each window as well if the auto-up doesn't work. If needed, to do this the door of the window you are calibrating must be closed. Roll the window all the way down. Hold the window down button for three seconds, then hold the window up button until the window is all the way up. Continue to hold it for another three seconds. Do each window one by one. If the auto-up feature works, then it's successfully calibrated.
__________________
Factory Trained and Certified Fisker Tech, operating independently out of Southern California.

Owner of Fix The Karma LLC
http://www.fixthekarma.com
Lormax is offline   Reply With Quote
Old 05-25-2014, 10:17 PM   #9 (permalink)
Senior Member
 
Join Date: Jun 2013
Posts: 256
Mentioned: 8 Post(s)
Tagged: 0 Thread(s)
Quoted: 43 Post(s)
Garage
Default

Quote:
Originally Posted by David Feld View Post
Thanks Lormax. I will try a hard reset (when its morning here so I don't piss off the neighbours when the alarm goes off). I have to find a good easy way to do the hard reset - I have never done it before.

I am in Toronto and the VW dealership that used to service my Fisker just told me their network to Fisker has been shut down and they cannot help me anymore at all until they get reconnected. Unfortunately, they don't know if that will ever happen - sad. Love this car, love you guys and want to keep it on the road.
i am in St. Catharines and am sorry to hear your news about Dixie VW. I had Lormax up to replace a relay at their service area so maybe they would let you use their facility if it needs to go in the direction of importing Lormax.
fiskerjim is offline   Reply With Quote
Old 05-25-2014, 10:18 PM   #10 (permalink)
Senior Member
 
Join Date: Nov 2011
Posts: 1,171
Mentioned: 23 Post(s)
Tagged: 1 Thread(s)
Quoted: 81 Post(s)
Default

They should be able to handle this one, actually. Worst case he'll probably need the DIS replaced.
__________________
Factory Trained and Certified Fisker Tech, operating independently out of Southern California.

Owner of Fix The Karma LLC
http://www.fixthekarma.com
Lormax is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Warning Display now flashing Ready and DEAD Car kwsmith007 Fisker Karma 14 10-30-2015 08:54 PM
New failure mode: display cluster blank ct-fiskerbuzz Fisker Karma 23 08-28-2013 07:20 PM
New Warning Display kwsmith007 Fisker Karma 2 03-03-2012 11:41 AM
DHarris, does the display no longer change from white to black? SoCalGuy Fisker Karma 13 01-08-2012 04:37 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -4. The time now is 08:03 PM.



Powered by vBulletin® Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0 PL2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.